import Foundation
let pattern = #"(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'
'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'\<\?php echo $3$4; \?\>' + ' : ' + $1$2''\)\; \?\>'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)