$re = '/(\')(\<\?php echo L10n\:\:message\(\'dialog.delete\', )(L10n\:\:label\()(.*?)(\); \?\>)(\')/m';
$str = '\'<?php echo L10n::message(\'dialog.delete\', L10n::label(MODULE)); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'client\', true)); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', array(\'module\' => L10n::label(\'frequency\'))); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'file\')); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'image\')); ?>\'';
$subst = "'\<\?php echo $3$4; \?\>' + ' : ' + $1$2''\)\; \?\>'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;