import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(')(\\<\\?php echo L10n\\:\\:message\\('dialog.delete', )(L10n\\:\\:label\\()(.*?)(\\); \\?\\>)(')";
final String string = "'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'\n"
+ "'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'\n"
+ "'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'\n"
+ "'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'\n"
+ "'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'";
final String subst = "'\\<\\?php echo $3$4; \\?\\>' + ' : ' + $1$2''\\)\\; \\?\\>'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}