using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')";
string substitution = @"'\<\?php echo $3$4; \?\>' + ' : ' + $1$2''\)\; \?\>'";
string input = @"'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'
'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}