re = /^([a-zA-Z]{2}\d{27})$/m
str = '0444845519
0444845519a
0444845519FFF
3235519
2654444444
123456789
12345678
111111111111111111111111111111
UA903052992990004149123456789
UA9030529929900041491234567895
UA90305299299000414912345678
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end