using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{2}\d{27})$";
string input = @"0444845519
0444845519a
0444845519FFF
3235519
2654444444
123456789
12345678
111111111111111111111111111111
UA903052992990004149123456789
UA9030529929900041491234567895
UA90305299299000414912345678
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}