# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-zA-Z]{2}\d{27})$"
test_str = ("0444845519\n"
"0444845519a\n"
"0444845519FFF\n"
"3235519\n"
"2654444444\n"
"123456789\n"
"12345678\n"
"111111111111111111111111111111\n"
"UA903052992990004149123456789\n"
"UA9030529929900041491234567895\n"
"UA90305299299000414912345678\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.