import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2}\\d{27})$";
final String string = "0444845519\n"
+ "0444845519a\n"
+ "0444845519FFF\n"
+ "3235519\n"
+ "2654444444\n"
+ "123456789\n"
+ "12345678\n"
+ "111111111111111111111111111111\n"
+ "UA903052992990004149123456789\n"
+ "UA9030529929900041491234567895\n"
+ "UA90305299299000414912345678\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}