#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]{2}\d{27})$"
Local $sString = "0444845519" & @CRLF & _
"0444845519a" & @CRLF & _
"0444845519FFF" & @CRLF & _
"3235519" & @CRLF & _
"2654444444" & @CRLF & _
"123456789" & @CRLF & _
"12345678" & @CRLF & _
"111111111111111111111111111111" & @CRLF & _
"UA903052992990004149123456789" & @CRLF & _
"UA9030529929900041491234567895" & @CRLF & _
"UA90305299299000414912345678" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")