import Foundation
let pattern = #"^(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1-10RD724
1-I94YUBU
1-HRF87G6
1-FV4IAE3
1-E30MNAI
1-10RD724
1-ED94GUQ
1-4J1QEY1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)