import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)$";
final String string = "1-10RD724\n"
+ "1-I94YUBU\n"
+ "1-HRF87G6\n"
+ "1-FV4IAE3\n"
+ "1-E30MNAI\n"
+ "1-10RD724\n"
+ "1-ED94GUQ\n"
+ "1-4J1QEY1";
final String subst = ",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}