// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)$").unwrap();
let string = "1-10RD724
1-I94YUBU
1-HRF87G6
1-FV4IAE3
1-E30MNAI
1-10RD724
1-ED94GUQ
1-4J1QEY1";
let substitution = ",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}