re = /^(.*)$/m
str = '1-10RD724
1-I94YUBU
1-HRF87G6
1-FV4IAE3
1-E30MNAI
1-10RD724
1-ED94GUQ
1-4J1QEY1'
subst = ',$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result