using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)$";
string substitution = @",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023";
string input = @"1-10RD724
1-I94YUBU
1-HRF87G6
1-FV4IAE3
1-E30MNAI
1-10RD724
1-ED94GUQ
1-4J1QEY1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}