use strict;
my $str = '1-10RD724
1-I94YUBU
1-HRF87G6
1-FV4IAE3
1-E30MNAI
1-10RD724
1-ED94GUQ
1-4J1QEY1';
my $regex = qr/^(.*)$/mp;
my $subst = ',$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";