// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$").unwrap();
let string = "LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL
^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}