use strict;
my $str = 'LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL
^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL
';
my $regex = qr/^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$/imp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}