re = /^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$/im
str = 'LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
стр ах
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL
^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end