import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\S]?LUL[\\s]?)+$|^([\\S]+LUL[\\s]?)+$|^[ах]+[\\s]*$";
final String string = "LUL LUL LUL LUL\n"
+ "blackufaLUL LUL LUL LUL\n"
+ "blackufaLUL as w qddd \n"
+ "blackufaLUL blackufaLUL\n"
+ "blackufaLUL \n"
+ "blackufaLUL\n"
+ "LUL \n"
+ "blackufaLUL\n"
+ "blackufaLUL blackufaLUL\n"
+ "blackufaLUL\n"
+ "аххахах\n"
+ "ахахах\n"
+ "хааха\n"
+ "страх \n"
+ "страхах\n"
+ "ахахах \n"
+ "фафывафывацуацлжыд жывшапд од lul\n"
+ "lul\n\n\n"
+ "^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL\n"
+ "^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}