const regex = /^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\S]?LUL[\\s]?)+$|^([\\S]+LUL[\\s]?)+$|^[ах]+[\\s]*$', 'im')
const str = `LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd
blackufaLUL blackufaLUL
blackufaLUL
blackufaLUL
LUL
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх
страхах
ахахах
фафывафывацуацлжыд жывшапд од lul
lul
^([\\S]+LUL[\\s]?)+\$ - blackufaLUL blackufaLUL
^([^\\S]?LUL[\\s]?)+\$ - LUL LUL LUL
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}