#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$"
Local $sString = "LUL LUL LUL LUL" & @CRLF & _
"blackufaLUL LUL LUL LUL" & @CRLF & _
"blackufaLUL as w qddd " & @CRLF & _
"blackufaLUL blackufaLUL" & @CRLF & _
"blackufaLUL " & @CRLF & _
"blackufaLUL" & @CRLF & _
"LUL " & @CRLF & _
"blackufaLUL" & @CRLF & _
"blackufaLUL blackufaLUL" & @CRLF & _
"blackufaLUL" & @CRLF & _
"аххахах" & @CRLF & _
"ахахах" & @CRLF & _
"хааха" & @CRLF & _
"страх " & @CRLF & _
"страхах" & @CRLF & _
"ахахах " & @CRLF & _
"фафывафывацуацлжыд жывшапд од lul" & @CRLF & _
"lul" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([\S]+LUL[\s]?)+$ - blackufaLUL blackufaLUL" & @CRLF & _
"^([^\S]?LUL[\s]?)+$ - LUL LUL LUL" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")