// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^master([-a-z]*.)?").unwrap();
let string = "master-dev.ciudad.com.ar
master-stg.ciudad.com.ar
master.ciudad.com.ar
algo.ciudad.com.master";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}