re = /^master([-a-z]*.)?/m
str = 'master-dev.ciudad.com.ar
master-stg.ciudad.com.ar
master.ciudad.com.ar
algo.ciudad.com.master'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end