#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^master([-a-z]*.)?"
Local $sString = "master-dev.ciudad.com.ar" & @CRLF & _
"master-stg.ciudad.com.ar" & @CRLF & _
"master.ciudad.com.ar" & @CRLF & _
"algo.ciudad.com.master"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")