$re = '/^master([-a-z]*.)?/m';
$str = 'master-dev.ciudad.com.ar
master-stg.ciudad.com.ar
master.ciudad.com.ar
algo.ciudad.com.master';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);