const regex = /^master([-a-z]*.)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^master([-a-z]*.)?', 'gm')
const str = `master-dev.ciudad.com.ar
master-stg.ciudad.com.ar
master.ciudad.com.ar
algo.ciudad.com.master`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}