package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^master([-a-z]*.)?`)
var str = `master-dev.ciudad.com.ar
master-stg.ciudad.com.ar
master.ciudad.com.ar
algo.ciudad.com.master`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}