use strict;
my $str = 'Test.jpg.tif
hilfe.opg.jpg
';
my $regex = qr/\.\w{3}\./p;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";