#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.\w{3}\."
Local $sString = "Test.jpg.tif" & @CRLF & _
"hilfe.opg.jpg" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)