# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\w{3}\././g;t' <<< "Test.jpg.tif
hilfe.opg.jpg
"