import Foundation
let pattern = #"^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ns-1354.awsdns-41.org
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1354.awsdns-41.org
ns.domaincontrol.com
ns-1.awsdns-36.net
ns.google.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)