using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$";
string input = @"ns-1354.awsdns-41.org
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1354.awsdns-41.org
ns.domaincontrol.com
ns-1.awsdns-36.net
ns.google.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}