package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$`)
var str = `ns-1354.awsdns-41.org
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1354.awsdns-41.org
ns.domaincontrol.com
ns-1.awsdns-36.net
ns.google.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}