import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ns\\-\\d{0,4}\\.awsdns\\-\\d\\d\\.(org|co\\.uk|net|com)$";
final String string = "ns-1354.awsdns-41.org\n"
+ "ns-1658.awsdns-15.co.uk\n"
+ "ns-52.awsdns-06.com\n"
+ "ns-807.awsdns-36.net\n\n"
+ "ns-1658.awsdns-15.co.uk\n"
+ "ns-52.awsdns-06.com\n"
+ "ns-807.awsdns-36.net\n"
+ "ns-1354.awsdns-41.org\n\n"
+ "ns.domaincontrol.com\n"
+ "ns-1.awsdns-36.net\n"
+ "ns.google.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}