// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$").unwrap();
let string = "ns-1354.awsdns-41.org
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1658.awsdns-15.co.uk
ns-52.awsdns-06.com
ns-807.awsdns-36.net
ns-1354.awsdns-41.org
ns.domaincontrol.com
ns-1.awsdns-36.net
ns.google.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}