#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ns\-\d{0,4}\.awsdns\-\d\d\.(org|co\.uk|net|com)$"
Local $sString = "ns-1354.awsdns-41.org" & @CRLF & _
"ns-1658.awsdns-15.co.uk" & @CRLF & _
"ns-52.awsdns-06.com" & @CRLF & _
"ns-807.awsdns-36.net" & @CRLF & _
"" & @CRLF & _
"ns-1658.awsdns-15.co.uk" & @CRLF & _
"ns-52.awsdns-06.com" & @CRLF & _
"ns-807.awsdns-36.net" & @CRLF & _
"ns-1354.awsdns-41.org" & @CRLF & _
"" & @CRLF & _
"ns.domaincontrol.com" & @CRLF & _
"ns-1.awsdns-36.net" & @CRLF & _
"ns.google.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")