re = /(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$/m
str = '04:05
50:20
00:59
00:60
88:40
00:02:03
01:02:03
88:00:50
00:00:45
02:77:35
00:04:80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end