const regex = /(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((0[1-9])|[^0]\\d):)?[0-5]\\d:[0-5]\\d$', 'gm')
const str = `04:05
50:20
00:59
00:60
88:40
00:02:03
01:02:03
88:00:50
00:00:45
02:77:35
00:04:80`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}