using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$";
string input = @"04:05
50:20
00:59
00:60
88:40
00:02:03
01:02:03
88:00:50
00:00:45
02:77:35
00:04:80";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}