import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((0[1-9])|[^0]\\d):)?[0-5]\\d:[0-5]\\d$";
final String string = "04:05\n"
+ "50:20\n"
+ "00:59\n"
+ "00:60\n"
+ "88:40\n"
+ "00:02:03\n"
+ "01:02:03\n"
+ "88:00:50\n"
+ "00:00:45\n"
+ "02:77:35\n"
+ "00:04:80";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}