package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$`)
var str = `04:05
50:20
00:59
00:60
88:40
00:02:03
01:02:03
88:00:50
00:00:45
02:77:35
00:04:80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}