use strict;
my $str = '04:05
50:20
00:59
00:60
88:40
00:02:03
01:02:03
88:00:50
00:00:45
02:77:35
00:04:80';
my $regex = qr/(((0[1-9])|[^0]\d):)?[0-5]\d:[0-5]\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}