// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(is)..\d\d(-)\d\d\s(ifsd\[)\d\d\d\d\](:)\s(Changing logical)\s(drive)\s\d\d\s(from \w\w to \w\w\w\w\W)").unwrap();
let string = "2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}