# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(is)..\d\d(-)\d\d\s(ifsd\[)\d\d\d\d\](:)\s(Changing logical)\s(drive)\s\d\d\s(from \w\w to \w\w\w\w\W)"
test_str = "2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE."
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.