import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(is)..\\d\\d(-)\\d\\d\\s(ifsd\\[)\\d\\d\\d\\d\\](:)\\s(Changing logical)\\s(drive)\\s\\d\\d\\s(from \\w\\w to \\w\\w\\w\\w\\W)";
final String string = "2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}