const regex = /(is)..\d\d(-)\d\d\s(ifsd\[)\d\d\d\d\](:)\s(Changing logical)\s(drive)\s\d\d\s(from \w\w to \w\w\w\w\W)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(is)..\\d\\d(-)\\d\\d\\s(ifsd\\[)\\d\\d\\d\\d\\](:)\\s(Changing logical)\\s(drive)\\s\\d\\d\\s(from \\w\\w to \\w\\w\\w\\w\\W)', 'g')
const str = `2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}