package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(is)..\d\d(-)\d\d\s(ifsd\[)\d\d\d\d\](:)\s(Changing logical)\s(drive)\s\d\d\s(from \w\w to \w\w\w\w\W)`)
var str = `2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}