re = /(is)..\d\d(-)\d\d\s(ifsd\[)\d\d\d\d\](:)\s(Changing logical)\s(drive)\s\d\d\s(from \w\w to \w\w\w\w\W)/
str = '2018-04-17T19:07:35-05:00 iswb01-12 ifsd[4189]: Changing logical drive 16 from OK to GONE.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end