import Foundation
let pattern = #"\/([^\/]+)\/?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://falloutboy.com/111
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}