import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([^\\/]+)\\/?$";
final String string = "http://falloutboy.com/111\n"
+ "http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki\n"
+ "http://www.adobe.com/ru/\n"
+ "http://www.mamba.ru/en/\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}